Computerwissen

Dies ist ein Begrüßungstext, der immer auf der QuA Landingpage (qa/index) angezeigt wird.

Hallo,
nach der Installation vorgeschlagener Updates für Ubuntu 14.04 LTS kann ich
mein Ubuntu nicht mehr nutzen. Eine Betriebssystemanmeldung ist zwar noch
möglich, doch danach erhalte ich einen leeren Desktop ohne Unity und Desktop-
Icons. Der Mauszeiger lässt sich zwar noch bewegen. Da aber keine Programmstarts (auch nicht per Maus-Rechts- oder Links-Klick für Programmaufrufe) und keine Systemeinstellungen anpassbar sind, ist mein Ubuntu derzeit nicht verwendbar. Selbst das Beenden des Betriebssystems ist nur per PC-Reset-Taste möglich. Was nun ... ?
Ich vermute, dass die Updates irgendwelche Systemeinstellungen (u.a. Treiber
bei der Grafikkarte ?) beschädigt haben und damit mein Ubuntu entschäft haben.
Aber wie gehe ich jetzt am sinnvollsten vor, damit möglichst keine Daten
verloren gehen und ich Ubuntu dann wieder nutzen kann. Als relativer Ubuntu-
Laie wäre ich an einem detaillierten Lösungsvorschlag interessiert.
Für Ihre Hilfe bedankt sich vorab - dieter53
Geschrieben in: Linux 16:53, 02. Dezember 2014
Beitrag teilen:

Akzeptierte Antwort

17:08, 10. Dezember 2014
Hallo,

in Ergänzung meiner Ausführungen vom 09.12.2014 (dort bitte nachlesen, um die eigentliche Lösung zu verstehen) möchte ich noch ergänzen, dass ich jetzt nach Kenntnis der genauen NVIDIA-Treiber-Bezeichnung ("NVIDIA binary driver in der Version '331.38-0ubuntu7.1' ") auf verschiedenen Internetseiten gelesen habe, dass auch andere Ubuntu-User von einem Bug zu diesem Treiber berichtet haben.
Ich habe daher diesen heute vorsorglich gegen einen alternativ angebotenen proprietären 'NVIDIA legacy binary driver . Version 304.117 von nvidia-304-updates' ausgetauscht und hoffe, dass dieser von Bugs verschont bleibt. Vielleicht hilft dieser Hinweis auch anderen Ubuntu-Usern.

Nette Grüße - dieter53
google icon

Wunderbar, dass Ihnen weiter geholfen werden konnte!

Wir würden uns sehr freuen, wenn Sie uns eine Bewertung auf Google hinterlassen:
Jetzt bewerten

Die Antwort ist derzeit minimiert Show
Antworten (8)
  • Akzeptierte Antwort

    09:06, 03. Dezember 2014
    In Ergänzung meiner gestrigen Anfrage habe ich noch einen Schnappschuss einer nach der Ubuntu-Anmeldung erscheinenden Anzeige "System program problem detected (Do you want to report the problem now? -> Abbrechen / Report problem) als Foto beigefügt. Ich kann zwar das 'Problem reporten', habe aber keinen Zugriff darauf, was das Problem eigentlich ist... ?
    Anhänge:
    google icon

    Wunderbar, dass Ihnen weiter geholfen werden konnte!

    Wir würden uns sehr freuen, wenn Sie uns eine Bewertung auf Google hinterlassen:
    Jetzt bewerten

    Die Antwort ist derzeit minimiert Show
  • Akzeptierte Antwort

    16:47, 04. Dezember 2014
    Hallo "Dieter53",

    zuerst einmal zum Report. davon haben wir leider nichts, genauso wenig wie vom Windows Fehlerreport. Solche Meldungen gehen an die Entwickler, die mit der Sammlung schneller auf Probleme reagieren können. Eine Rückmeldung gibt es leider nur in Form eines Updates. Die Meldung habe ich auch auf einigen Rechnern von Zeit zu Zeit.

    Vermutlich hatten Sie unter Zusätzliche Treiber einen proprietären ausgewählt, dies bereitet bei einigen Grafikkarten Probleme beim Update. Diese erhalten dann irgendeinen nur teilweise funktionierenden Treiber.

    Sie müssen den proprietären Treiber des Herstellers erneut installieren. Dazu starten Sie im Bootmenü (F8) den Rechner im sicheren Grafikmodus. Hier werden wieder die einfachen Vesa-Treiber verwendet. Der Desktop dürfte auch das träge reagieren, aber reagieren.

    Gehen Sie dann in den Systemeinstellungen (Zahnradmenü) auf Software&Aktualisierung. Wechseln Sie im neune Fenster auf das Register Zusätzliche Treiber. Nun werden Treiber gesucht und Sie müssen nur den für Ihre Grafikkarte aktivieren.

    Nach der Installation ist eventuell noch ein Neustart möglich, dann sollte der Desktop normal reagieren.

    Sollte dies nicht klappen, müsste ich mehr über Ihren Rechner wissen. Grundsätzlich kann ich nie zu viel über einen Rechner wissen, nur zu wenig. Wichtig sind hierbei die Grafikkarte, die CPU und das Mainboard bzw. der Chipsatz, mehr Informationen schaden nicht.

    Mit freundlichen Grüßen,
    Dirk Kleemann
    google icon

    Wunderbar, dass Ihnen weiter geholfen werden konnte!

    Wir würden uns sehr freuen, wenn Sie uns eine Bewertung auf Google hinterlassen:
    Jetzt bewerten

    Die Antwort ist derzeit minimiert Show
  • Akzeptierte Antwort

    22:44, 04. Dezember 2014
    Hallo Herr Kleemann,

    zunächst Danke für Ihre Bemühungen, um mein Problem zu lösen.

    Leider war Ihr Vorschlag über den abgesicherten Modus die korrekte Grafik wieder herzustellen, um danach die gewohnte Unity wieder vorzufinden nicht erfolgreich. (Ich hatte alternativ die "Erweiterten Optionen für Ubuntu (Recovery Mode)" des GNU GRUB-Bootloaders (Version 2.02) verwendet, da F8 für meine Multiboot-Umgebung nicht geeignet war:

    Das erwähnte Zahnradsymbol war nur zum Zeitpunkt 'vor dem Login' (mit den nicht hilfreichen Optionen "Bereitschaft" und "Herunterfahren") sichtbar, 'nach dem Login' nicht mehr -> es erscheint auf dem leeren Desktop lediglich die bereits genannte Fehlermeldung "System program problem detected" mit der Option, per "Reset-Taste" den PC auszuschalten.

    Daher nachfolgend die zur Problemlösung benötigten Informationen:

    a) Grafikkarte: NVIDIA Corporation GF116 (Geforce GTX 550 Ti) (mit dem lt. Linux Mint 16) empfohlenem propritären'nvidia-319.32-0ubuntu7'-Treiber NVIDIA binary Xorg driver, kernel module and VPAU library)
    b) Prozessor: AMD Phenom (tm) II X4 965 Processor x 4
    c) Mainboard: GIGABYTE Socket AM3 GA-870A-UD3

    Auf dem PC, auf dem das genannte Ubuntu-Start-Problem auftritt, sind außerdem noch einige Windows-Versionen sowie als weitere Linux-Distribution 'Mint 16 Petra' (jeweils in 32-Bit-Versionen) installiert. Von letztgenannter Linux-Distribution aus habe ich auch Zugriff auf die Ordner des beschädigten Ubuntu 14.04 LTS.

    1. Lässt sich evtl. das Problem bei dieser Konstellation anhand von irgendwelchen Fehlerprotokollen auf dem defekten Ubuntu-System analysieren ? Dazu wäre es wichtig zu wissen, welche Dateien für die Analyse durch einen Experten benötigt würden.
    2. ... und gibt es Möglichkeiten über die "Erweiterten Optionen für Ubuntu (mit der Option >c< )" per Befehlszeile mit geeigneten Befehlen das defekte Ubuntu wieder funktionsfähig zu machen (anstelle der sonst über Terminal einzugebenden Befehle) ?
    3. ... oder gibt es eine Art Upgrade-Installation a la Windows, bei der installierte Programme und Einstellungen erhalten bleiben (evtl. mit der neuen Ubuntu 14.10-Version) ?

    Ich hoffe, dass diese Informationen und Vorschläge für die Problembehebung hilfreich sind und bitte Sie um Ihre Rückinfo ! Mit freundlichen Grüßen - dieter53
    google icon

    Wunderbar, dass Ihnen weiter geholfen werden konnte!

    Wir würden uns sehr freuen, wenn Sie uns eine Bewertung auf Google hinterlassen:
    Jetzt bewerten

    Die Antwort ist derzeit minimiert Show
  • Akzeptierte Antwort

    15:56, 06. Dezember 2014
    Hallo Dieter53,

    der Grafiktreiber, der bei mint eingestellt ist,lässt sich leider nicht so einfach ohne grafische Oberfläche einstellen. Sie hätten diesen Treiber vor dem update deaktivieren sollen, meist ist dies nicht nötig, aber bei einigen Konstellation wie bei Ihrer ist es sicherer. Das weiß man leider oft erst im Nachhinein.

    Die Erweiterten Optionen waren schon richtig, dort haben Sie den Punkt failsafeX für den abgesicherten Grafikmodus gewählt? Damit müssten Sie wie in meiner ersten Antwort geschrieben mit dem einfachen Standardtreiber das System starten.

    Sollte dies nicht klappen, versuchen Sie über den Textmodus erst einmal ein Update des Systems, oft ist der Fehler nämlich schon behoben:

    1. Mit der Tastenkombination [Str]+[Alt]+[F1] gelangen Sie in die Textkonsole.
    2. Melden Sie sich hier mit Benutzernamen und Passwort an.
    3. Geben Sie die folgenden Befehle ein:
    4. sudo apt-get update    (Aktualisierung der Paketlisten)

      sudo apt-get upgrade  (Einspielen aller Updates)

    5. Starten Sie danach den Rechner mit dem Befehl "sudo shutdown -r now" neu.

    Durch den Befehl sudo wird der nachfolgende Befehl mit root-Rechten (entspricht dem Administrator in Windows) ausgeführt. Das Passwort das Sie eingeben müssen, ist das Passwort des Benutzers mit dem Sie im Linuxystem sind, dieses haben Sie bei der Installation erstellt. Das zweite häufige Problem ist, das scheinbar nichts angenommen wird, wenn Sie das Passwort eingeben, dies ist eine Sicherheitsfunktion, das Passwort wird angenommen, es werden nur keine Zeichen - auch keine Platzhalter * - bei der Eingabe dargestellt.

    Übrigens mit shutdown im Textmodus können Sie das System immer wieder herunterfahren, wenn das grafische System hängt. Ersetzen Sie -r durch -h wird der Rechner auch ausgeschaltet.

    Mit freundlichen Grüßen,
    Dirk Kleemann
    google icon

    Wunderbar, dass Ihnen weiter geholfen werden konnte!

    Wir würden uns sehr freuen, wenn Sie uns eine Bewertung auf Google hinterlassen:
    Jetzt bewerten

    Die Antwort ist derzeit minimiert Show
  • Akzeptierte Antwort

    14:07, 07. Dezember 2014
    Sehr geehrter Herr Kleemann,

    mein "Danke mit *****" für Ihre (am Samstag nicht unbedingt erwartete) Antwort. Ich habe Ihre Empfehlungen befolgt, welche jedoch nicht die erhoffte Lösung brachten.

    Daraufhin habe ich versucht, im Internet eine Lösung zu finden, u.a. mit dem Ziel die nvidia-Grafikkarte manuell zu installieren. Ich bin dabei wie folgt vorgegangen:
    1. Download des von "Linux Mint 16" her bekannten Grafikkarten-Treibers von der nVIDIA-Downloadseite und Ablage der 'NVIDIA-Linux-x86-319.32.run'-Datei im Download-Ordner der defekten Ubuntu-Version (Aktionen innerhalb 'Linux Mint 16')
    2. Start des defekten Ubuntu (mit dem noch funktionierenden Login, anschließender bereits benannter Fehleranzeige und weiterhin leerem Desktop,ohne Dash,ohne Icons)
    3. danach Wechsel zur Textkonsole mit Tastenkombination [Str]+[Alt]+[F1]
    4. Nochmaliges Login in der Textkonsole
    5. XServer beenden mit 'sudo service lightdm stop'
    6. RunLevel-Wechsel mit 'sudo telinit 2'
    7. danach 'cd Downloads' und Anzeige des genauen Dateinamens mit 'dir *.run'
    8. Installation des gedownloadeten Treiber ('sudo sh NVIDIA-Linux-x86-319.32.run')
    9. Lizenz akzeptiert
    10. Während der anschließenden Installation erhalte ich den Hinweis, dass ein gleichartiger nVidia-Treiber bereits vorhanden ist. (ich habe dies dennoch nochmals installiert - brachte aber auch nichts - außer ein paar Fehlermeldungen wegen DKMS)

    Ich stelle mir jetzt die Frage, ob mein Problem tatsächlich nur ein Grafikkarten-Treiberproblem ist, da ich mich anfangs doch noch anmelden kann, bei der Grafikkartentreiber-Neuinstallation auch der richtigte Grafikkartentreiber erkannt wurde -und die Neuinstallation möglicherweise überflüssig war ...?

    Ich erhalte - nach Wechsel in den Textkonsolen-Wechsel folgende Anzeigen:
    'Ubuntu 14.04.1 LTS Ubuntu-GA-870A-UD3 tty1

    Ubuntu-GA-870A-UD3 login:
    * Starting NVIDIA Persistenced Daemon [ OK ]
    * Stopping NVIDIA PRIME Power Saving Mode [ OK ]
    * Starting NVIDIA Persistenced Daemon [fail] '

    Können Sie anhand vorgenannter Darstellung und letztgeannter Fehlermeldung evtl. erkennen, was ich evtl. falsch mache oder was ich noch tun könnte ? (ggf. letztlich bereits angefragte Upgrade-Installation mit Ubuntu 14.10 (über Ubuntu 14.04 LTS - geht das überhaupt?)

    Vorab "Danke" für Ihre Rückmeldung !

    Mit freundlichen Grüßen - dieter53
    google icon

    Wunderbar, dass Ihnen weiter geholfen werden konnte!

    Wir würden uns sehr freuen, wenn Sie uns eine Bewertung auf Google hinterlassen:
    Jetzt bewerten

    Die Antwort ist derzeit minimiert Show
  • Akzeptierte Antwort

    15:14, 08. Dezember 2014
    Hallo dieter53,

    ich versuche immer alle Fragen vor dem Wochenende zu beantworten, wenn ich jedoch am Freitag den ganzen Tag bei einem Kunden bin, muss ich dies am Samstag oder zur Not Sonntag nachholen. Aber bitte gewöhnen Sie sich nicht daran.

    Sie haben mir den nächsten Lösungsansatz vorweggenommen, allerdings startet der Daemon ja nicht. Dies passiert hin und wieder wenn der neuere Treiber eigentlich nur für die neueste Ubuntu Version getestet ist. Dies passiert sowohl bei Nvidia als auch bei AMD hin und wieder bei einigen Grafikkarten. Meist passt eine Einstellung des alten Systems nicht mehr. Leider ist als Benutzer des Systems nur schwer zu beheben, oft ist das Problem dann einen Monat später wieder behoben, das hilft aber auch nicht wirklich.

    Das Upgrade auf die aktuelle Ubuntu Version 14.10 dürfte die einfachste und schnellste Lösung sein. Die Aktualisierung kann mit jedem Installationsmedium von Ubuntu 14.10 durch geführt werden. Der Installationsassistent erkennt alte Varianten und bietet die Möglichkeit an, diese zu ersetzen oder das Update durchzuführen. Letzteres sollten Sie machen, dabei bleiben Einstellungen so weit möglich, installierte Porgramme und eigene Dateien erhalten.

    Die aktuelle Version erhalten Sie hier, 32 Bit, wenn der Rechner eine älteren Prozessor hat, ab Pentium 4 (einige Versionen ab 2005) oder Athlon64 Sie die 64 Bit Version verwenden.

    Am Einfachsten kopieren Sie diese mit dem Programm Universal USB Installer auf einen USB-Stick zur Installation. Ubuntu ist für eine CD zu groß, Sie müssten das Image sonst auf DVD brennen, aber die USB-Variante ist einfacher und deutlich schneller.

    Mit freundlichen Grüßen,
    Dirk Kleemann
    google icon

    Wunderbar, dass Ihnen weiter geholfen werden konnte!

    Wir würden uns sehr freuen, wenn Sie uns eine Bewertung auf Google hinterlassen:
    Jetzt bewerten

    Die Antwort ist derzeit minimiert Show
  • Akzeptierte Antwort

    19:49, 09. Dezember 2014
    Sehr geehrter Herr Kleemann,

    zunächst einmal etwas Erfreuliches: Mein Ubuntu 14.04 LTS läuft wieder. Der Weg dorthin war allerdings sehr abenteuerlich:

    1. Nach den vorausgegangenen erfolglosen Versuchen, mein Ubuntu 14.04 LTS wieder nutzbar zu machen, habe ich eine Update-/Upgrade-Installation versucht :

    Versuch 1: die empfohlene 'per auf einem Speicher-Medium (DVD bzw.USB-Stick) befindlichem Ubuntu 14.10' war in meinem Fall nicht hilfreich, da hier (mit DVD) keine Update-Option vorhanden ist oder ich diese möglicherweise übersehen habe (.. ?).

    Versuch 2: Ich habe alternativ das Upgrade aus dem defekten Ubuntu heraus gewählt :

    a) beim defekten Ubuntu 14.04 LTS die Textkonsole per [Str]+[Alt]+[F1] geöffnet:

    b) dort Eingabe von 'sudo apt-get update' und 'sudo do-release-upgrade'.

    c) Ergebnis (leider): "Keine neue Freigabe gefunden", da Ubuntu-Langzeit-Version (14.04 LTS) voreingestellt war und keine diesbezügliche Änderung via grafischer Oberfläche in ein normales 'Ubuntu 14.04' möglich war.

    d) schließlich im Internet den meiner Meinung nach sehr empfehlenswerten Youtube-Film "Version Upgrade/Update von Ubuntu 14.04 LTS zu 14.10 der neuesten Ubuntu Version [Deutsch/German]" auf 'https://www.youtube.com/watch?v=QfTFZvWk1Wg&list=UUc6YNcod5OUrlxUQbyHguAw' gefunden, wo notwendige Vorbereitungen beim Upgrade von einer LTS-Version auf eine Normal-Version sehr gut erklärt sind.

    e) mittels vorgenannter Upgrade-Variante wurde dann das Upgrade auf Ubuntu 14.10 vorgenommen; nach ca. 1 1/2 Std.+ Neustart von Ubuntu 14.10 jedoch leider wieder die gleiche Fehlermeldung wie zu Anfang meiner Anfrage.

    d.h. die Upgrade-Varianten brachten leider nicht die erhoffte Lösung.

    2.Eine - zum Glück noch gefundene - Datensicherung meiner Partitionen von Ende November 2014 (als Ubuntu 14.04 LTS noch funktionierte) war schließlich der Schlüssel zum Erfolg.

    Nach erfolgreichem Restore der Ubuntu 14.04 LTS-Partition konnte ich dann im Nachhinein auch die genauere Fehlerursache nachvollziehen, denn in 2 Update-Versuchen (1 x mit und 1 x ohne '3 angebotene NVIDIA-Treiber-Aktualisierungen' von:
    - NVIDIA binary driver - version 331.38 27,7 MB
    - NVIDIA CUDA Laufzeitbibliothek 4,2 MB
    - NVIDIA OpenGL ICD 4,2 MB)
    stellte sich heraus, dass der NVIDIA binary driver (in der Version '331.38-0ubuntu7.1' anstelle vorhandenem '331.38-0ubuntu7') den Unterschied zwischen fehlerhaftem und funktionierendem Ubuntu 14.04 LTS ausmacht.

    Ich verzichte daher vorerst darauf, in der 'Ubuntu 14.04 LTS'-Version diese 'Übeltäter' zu installieren und hoffe, bei einem der nächsten 'automatischen' Updates diese nicht doch unbemerkt zu installieren. (da helfen wohl nur regelmäßige Datensicherungen).

    Auch wenn ich mein Problem letztlich eigentlich 'simple' klären konnte, bleibt noch eine
    ungeklärte Frage: Wie funktioniert eine Upgrade-Installation von einer LTS-Version zu einer Normal-Version via DVD ? (evtl. könnten Sie dieses Thema in 'Linux-Insider' einmal detailliert beschreiben, ggf. auch mit einem Hinweis auf den empfehlenswerten Youtube-Film "Version Upgrade/Update von Ubuntu 14.04 LTS zu 14.10 der neuesten Ubuntu Version [Deutsch/German]" auf 'https://www.youtube.com/watch?v=QfTFZvWk1Wg&list=UUc6YNcod5OUrlxUQbyHguAw' )

    Für mich war der beschrittene Weg doch hilf- und lehrreich, habe ich als 'Ubuntu-Laie' auch dank Ihrer Hilfe, Herr Kleemann, einige Neuigkeiten in Sachen "Ubuntu / NVIDIA und wie man ggf. künftig ein derartiges Problem löst" kennengelernt.

    Ich bedanke mich nochmals für die Geduld zu den bei der Fehlerlösung aufgetretenen Fragen, und verbleibe bis zum nächsten Mal - als Neu-Ubuntu-User dieter53
    google icon

    Wunderbar, dass Ihnen weiter geholfen werden konnte!

    Wir würden uns sehr freuen, wenn Sie uns eine Bewertung auf Google hinterlassen:
    Jetzt bewerten

    Die Antwort ist derzeit minimiert Show
  • Akzeptierte Antwort

    16:25, 12. Dezember 2014
    Hallo Dieter53,

    vielen Dank für die ausführlichen Informationen. So etwas hilft mir später auch immer weiter. Das Treiberproblem hängt leider oft nicht nur von einer einzigen GPU ab und deren Familie sondern teilweise auch von der Grafikkarte und deren Hersteller. Bei mir selbst gibt es überhaupt keine Probleme mit dem Treiber, allerdings hatte ich so etwas schon mal bei einem früheren Update.

    Was Sie einstellen müssen, um das Update auf einen nicht LTS Version zu bekommen, haben wir ja auch in der Dezemberausgabe geschrieben. Beim Upgrade über ein Installationsmedium müssen Sie da allerdings nichts beachten.

    Mit freundlichen Grüßen,
    Dirk Kleemann
    google icon

    Wunderbar, dass Ihnen weiter geholfen werden konnte!

    Wir würden uns sehr freuen, wenn Sie uns eine Bewertung auf Google hinterlassen:
    Jetzt bewerten

    Die Antwort ist derzeit minimiert Show
Login Bild

Bitte melden Sie sich an um eine Antwort zu verfassen

Sie müssen angemeldet sein um eine Antwort zu verfassen. Sie können hierfür das Anmeldeformular rechts nutzen oder sich registrieren.

Hier registrieren »