Computerwissen

Dies ist ein Begrüßungstext, der immer auf der QuA Landingpage (qa/index) angezeigt wird.

Hallo und guten Tag,

ich möchte gerne von der Soundkarte aufnehmen mit Audacity. Leider funktioniert es bisher nicht. Es ist nach dem Aufnehmen nur ein Rauschen zu hören - ich habe im WEB schon nach Lösungen gesucht aber nichts gefunden was mir weitergeholfen hat. Teilweise wurde das Öffnen von Menues empfohlen die bei meiner Audacity-Version so nicht vorhanden sind.

Ein Foto der Oberfläche meiner Audacity-Version habe ich beigefügt. Ich hoffe die Soundkarte lässt sich aus den Fotos erkennen.

Schnelle Antwort wäre super.

Freundliche Grüsse
ZumbuschA
Geschrieben in: Freeware & Open Source 00:17, 15. Januar 2020
Beitrag teilen:

Akzeptierte Antwort

20:39, 25. Februar 2020
Hallo Herr Kleemann,

ich hatte die von Ihnen vorgeschlagenen Schritte befolgt. Ein Problem gab/gibt es bei der Einstellung des PulseAudio Lautstärkereglers !! Hier konnte ich diese exakte Einstellung Ihres Vorschlages nicht vornehmen weil diese Auswahl nicht besteht.

Es bestehen folgende Möglichkeiten:

- Audio Adapter (Unitek Y-247A) Analog Mono
- Monitor of Audio Adapter (Unitek Y-247A) Analog Stereo
- Eingebautes Tongerät Analog Stereo
- Monitor of Eingebautes Tongerät Digital Stereo (IEC958)

Wie Sie sehen ist die Auswahl "Monitor of eingebautes Tongerät Analog Stereo" leider nicht vorhanden - statt "analog" gibts nur "digital" oder ohne "Monitor"

Ich habe aber jetzt die 2. Auswahl ( Monitor of Audio Adapter (Unitek Y-247A) Analog Stereo ) und bei Audacity als Eingang "pulse: Line:0" und als Ausgang "pulse" eingestellt - und damit funktioniert es !!! :) ... endlich !!!


Ich habe jetzt natürlich auch in der "alten, gestörten" Ubuntu-Version diese Einstellungen ausprobiert - dort funktioniert es ebenso mit dieser Einstellung im Lautstärkeregler !!

Herzlichen Dank für die tolle Unterstützung an Sie und auch an Noha !!

Freundliche Grüsse
ZumbuschA
google icon

Wunderbar, dass Ihnen weiter geholfen werden konnte!

Wir würden uns sehr freuen, wenn Sie uns eine Bewertung auf Google hinterlassen:
Jetzt bewerten

Die Antwort ist derzeit minimiert Show
Antworten (33)
  • Akzeptierte Antwort

    17:25, 16. Januar 2020
    Hallo ZumbuschA,

    ich benötige die gesamte Ausgabe von lspci und lsusb, da fehlt etwas.

    zu sehen ist zwar eine Soundkarte, das ist aber die der Grafikkarte, die über HDMI verwendet wird, es muss noch einen andere verbaut sein, die die normalen Audioanschlüsse bedient.

    Sie können in Audacity auch mal den Anschluss umstellen, ich vermute das dort mehrere Eingänge zur Auswahl stehen.

    Der Ton von Videos und so funktioniert aber bereits?

    Mit freundlichen Grüßen
    Dirk Kleemann
    google icon

    Wunderbar, dass Ihnen weiter geholfen werden konnte!

    Wir würden uns sehr freuen, wenn Sie uns eine Bewertung auf Google hinterlassen:
    Jetzt bewerten

    Die Antwort ist derzeit minimiert Show
  • Akzeptierte Antwort

    21:02, 16. Januar 2020
    Hallo Herr Kleemann,

    Ja - mit der Wiedergabe von Audio- oder Videodateien habe ich kein Problem, da funktioniert alles.

    Was Sie wohl mit dem Umstellen des Anschlusses meinen habe ich schon gemacht - es stehen haufenweise Eingänge zur Verfügung, ich habe aber keinen gefunden der die Soundkarte aufruft.

    Bei diversen Erklärungen im Web habe ich auch den Hinweis gefunden man solle in Audacity den sog. Stereomix aufrufen - aber den finde ich nirgends obwohl ich schon soweit alles versucht habe.

    Ich habe mal ein Foto mit dem wohl fehlenden Teil von Ispci und Isusb beigefügt - ebenso Handyfotos der Eingänge die Audacity anbietet - ein Bildschirmfoto war davon nicht möglich - aber ich hoffe Sie können auf den Handyfotos auch genug erkennen.

    Freundliche Grüsse
    ZumbuschA
    google icon

    Wunderbar, dass Ihnen weiter geholfen werden konnte!

    Wir würden uns sehr freuen, wenn Sie uns eine Bewertung auf Google hinterlassen:
    Jetzt bewerten

    Die Antwort ist derzeit minimiert Show
  • Akzeptierte Antwort

    14:08, 18. Januar 2020
    Hallo ZumbuschA,

    Sie haben einen HDA Audiochip von ATI. Bei Audacity können Sie diesen direkt ansprechen, egal ob die andere gerade die aktive Karte ist..

    Die Aus- bzw. Eingänge mit dem namen systemdefault und default sind die vom System gemappten Ein- und Ausgänge. Je nachdem welche Soundkarte aktiv ist.

    Wenn Ihr Monitor einen Lautsprecher hat und der Ton per HDMI kommt, wird die Soundkarte der Grafikkarte aktiv sein und dann als systemdeafult und default eingestellt sein. Kommt der Sound aus Boxen, die per normalen Audiokabel angeschlossen sind, ist die Ati die aktive Soundkarte.

    Die Pulse Einträge sind vom Pulseaudio, das ist das Soundsystem, das Linux verwendet. Auch hier kann mal die eine, mal die andere aktiv sein.

    Sehen Sie sich mal diese Anleitung von Audacity an.

    Grundsätzlich sollten Sie für gute Aufnahmen jedoch eine zusätzliche USB-Soundkarte verwenden oder gleich ein per USB angeschlossenes Mikrofon, in dem die Soundkarte integriert ist. Alle intern verbauten Soundchips haben das Problem, das es hochfrequente Störungen durch die anderen Chips vor allem der CPU und der GPU gibt. Dadurch wird immer ein Rauschen im Audiosignal bleiben. Für eine Kommunikation etwa mit Skype ist dies zu vernachlässigen, nur unschön. Aber wenn Sie etwas aufnehmen, stört das sehr.

    Mit freundlichen Grüßen
    Dirk Kleemann
    google icon

    Wunderbar, dass Ihnen weiter geholfen werden konnte!

    Wir würden uns sehr freuen, wenn Sie uns eine Bewertung auf Google hinterlassen:
    Jetzt bewerten

    Die Antwort ist derzeit minimiert Show
  • Akzeptierte Antwort

    16:43, 18. Januar 2020
    Hallo Herr Kleemann,

    Ihren Tip bezüglich der USB-Soundkarte habe ich befolgt und mir eine bestellt - bisher war mein Linux-pc nur ein Nebendarsteller aber jetzt bin ich ja dabei ihn auf Vordermann zu bringen weil er nun der Haupt-PC ist .

    ... der Sound kommt übrigens aus den Boxen, mein Monitor hat keinen Lautsprecher. ... Ich mach mal Fotos dazu wie sich die Oberfläche von Audacity darstellt wenn ich aufnehme und wenn ich die Aufnahme abspiele - vielleicht können Sie aus den Fotos Rückschlüsse ziehen.

    Wenn ich Systdefault Frontmicro anwähle zeigt sich optisch ein Eingang - die grafische Tonkurve ist jedoch ganz flach - halt entsprechend dem Rauschen das beim Abspielen zu Hören ist. Beim Abspielen ist optisch auch zu sehen dass mit dem Programm "etwas passiert" - aber zu hören ist halt nur Rauschen.

    Hat es einen besonderen Grund dass Sie zu einer USB-Soundkarte raten? ... ich habe probeweise an einem der Steckplätze mal eine Soundkarte eingesteckt (siehe Foto) - kann es sein dass das System diese an diesem Steckplatz nicht erkennt?



    Freundliche Grüsse
    ZumbuschA
    google icon

    Wunderbar, dass Ihnen weiter geholfen werden konnte!

    Wir würden uns sehr freuen, wenn Sie uns eine Bewertung auf Google hinterlassen:
    Jetzt bewerten

    Die Antwort ist derzeit minimiert Show
  • Akzeptierte Antwort

    19:08, 20. Januar 2020
    Hallo ZumbuschA,

    alles was Sie in das Gehäuse einbauen bekommt die hochfrequenten Störungen der anderen Geräte mit, vor allem von CPU und GPU. Eine zusätzliche interne Karte ändert daran nichts. Deshalb rate ich zur USB Soundkarte. In der Regel sind diese auch viel einfacher zu installieren, selbst unter Linux reicht ein Einstecken und sie funktioniert.

    Die Soundkarte dürfte bei lpci als C-Media aufgeführt sein.

    Wir gucken jetzt erstmal, ob das Mikrofon überhaupt funktioniert, oder ob es an Audacity liegt. Gehen Sie in den Einstellungen des Systems auf Klang. im Register Eingang können Sie die einzelnen Eingänge testen und auch die Lautstärke einstellen.

    Mit freundlichen Grüßen
    Dirk Kleemann
    google icon

    Wunderbar, dass Ihnen weiter geholfen werden konnte!

    Wir würden uns sehr freuen, wenn Sie uns eine Bewertung auf Google hinterlassen:
    Jetzt bewerten

    Die Antwort ist derzeit minimiert Show
  • Akzeptierte Antwort

    19:15, 20. Januar 2020
    Hallo Herr Kleemann,

    in den Einstellungen habe ich bei Klang schon früher gleich nachgesehen - aktiv ist der Line-Ausgang (eingebautes Tongerät).

    Die bestellte USB-Soundkarte sollte die nächsten Tage ankommen. Dann werden wir sehen ob dann das Problem mit dem Aufnehmen per Audacity funktioniert.

    Freundliche Grüsse
    ZumbuschA
    google icon

    Wunderbar, dass Ihnen weiter geholfen werden konnte!

    Wir würden uns sehr freuen, wenn Sie uns eine Bewertung auf Google hinterlassen:
    Jetzt bewerten

    Die Antwort ist derzeit minimiert Show
  • Akzeptierte Antwort

    16:55, 22. Januar 2020
    Hallo und guten Tag,

    die USB-Soundkarte ist da und angeschlossen und funktioniert.

    Bei Audacity hat sich dadurch bisher leider nichts verändert - optisch wird bei Aufnahme und Abspielen etwas angezeigt aber bei den möglichen Ausgabegeräten funktioniert nichts.
    Bei Pulse und Default hört man ein Rauschen - die Pegel bei der optischen Darstellung sehen aus wie bei einer normalen Aufnahme aber Musik ist nicht zu hören.

    Auswahl bei Klang = Audio Adapter (Unitek Y-247 A)

    Aktueller Ausdruck lspci und lsusb ist beigefügt. Ebenso eine Systemmitteilung über das angeschlossene Audiogerät.

    Freundliche Grüsse
    ZumbuschA
    google icon

    Wunderbar, dass Ihnen weiter geholfen werden konnte!

    Wir würden uns sehr freuen, wenn Sie uns eine Bewertung auf Google hinterlassen:
    Jetzt bewerten

    Die Antwort ist derzeit minimiert Show
  • Akzeptierte Antwort

    14:29, 24. Januar 2020
    Hallo ZumbuschA,

    der USB-Adapter ist vorhanden und der Chip wird laut Internet direkt unterstützt. Sehen Sie mal in Audacity unter dem Lautstärkeregler für das Microfon. in dem Pulldownmenü steht ALSA, können Sie da noch etwas anderes auswählen?

    Ich habe nicht genau die gleiche Soundkarte, aber einen mit einem ähnlichen, etwas älterem, Chip, diese habe ich an meinen Testrechner gehängt und es funktioniert direkt.

    Wir müssen uns mal dem System an sich zu wenden. Installieren Sie mal den Alsamixer und testen Sie ob Sie hier Zugriff auf das Mikrofon bekommen.

    Mit freundlichen Grüßen
    Dirk Kleemann
    google icon

    Wunderbar, dass Ihnen weiter geholfen werden konnte!

    Wir würden uns sehr freuen, wenn Sie uns eine Bewertung auf Google hinterlassen:
    Jetzt bewerten

    Die Antwort ist derzeit minimiert Show
  • Akzeptierte Antwort

    13:44, 25. Januar 2020
    Hallo Herr Kleemann,

    die USB-Soundkarte hat kein eingebautes Mikrofon - ich habe ein Mikrofon an der Buchse angeschlossen aber das System zeigt keine Reaktion.

    Einige Infos die der Alsamixer bietet sind per Foto beigefügt.

    Bei Audacity habe ich keine Auswahl - es ist nur ALSA möglich.

    Freundliche Grüsse
    ZumbuschA
    Anhänge:
    google icon

    Wunderbar, dass Ihnen weiter geholfen werden konnte!

    Wir würden uns sehr freuen, wenn Sie uns eine Bewertung auf Google hinterlassen:
    Jetzt bewerten

    Die Antwort ist derzeit minimiert Show
  • Akzeptierte Antwort

    15:12, 26. Januar 2020
    Hallo ZumbuschA,

    es ist gut das sich dort nur ALSA befindet, manchmal mischt sich da etwas anderes ein, das dies nicht der Fall ist, wissen wir nun.

    Der Alasamixer regelt die verschiedenen Soundkarten und die Eingänge, alle Programme greifen durch ALSA auf diese Geräte zu.

    Man sieht bei ihnen, das alle drei Soundkarten angezeigt werden, als default ist HDA ATI SB eingestellt. Dies ist die interne Karte, die auch für die Front- und Rear Ein-/Ausgänge zuständig ist. Und die Einstellungen der Karte sieht man auf dem großen Bild. Mit F6 können Sie auch auf USB Audio wechseln.

    Stellen Sie mal den Punkt Line Boost höher so um die 50 und testen Sie dann noch mal.

    Mit freundlichen Grüßen
    Dirk Kleemann
    google icon

    Wunderbar, dass Ihnen weiter geholfen werden konnte!

    Wir würden uns sehr freuen, wenn Sie uns eine Bewertung auf Google hinterlassen:
    Jetzt bewerten

    Die Antwort ist derzeit minimiert Show
  • Akzeptierte Antwort

    19:49, 26. Januar 2020
    Hallo Herr Kleemann,

    ich habe eben die Regler mal alle hochgefahren - Audacity nimmt nun das Rauschen lauter auf :(

    ... komischerweise zeigen die Regler bei Audacity auch ordentlichen Eingang - nur hat das mit der Musik die auf dem Rechner läuft und die eigentlich aufgezeichnet werden soll nichts zu tun - die Regler schlagen aus auch wenn ich die Musik abstelle - also ist es keine Reaktion auf das was über die Soundkarte zu hören ist.

    Beim Abspielen des Rauschens ist was zu hören bei Pulse und bei default. .... aber immerhin: ... das Rauschen ist außerordentlich gut und laut zu hören ....

    Wäre jetzt nur noch das Aufnehmen ...... ich habe alle Möglichkeiten durchprobiert was die Eingänge bei Audacity hergeben - ich habe alles weggeklickt wo die Pegel schon verrückt gespielt haben bevor ich überhaupt Musik angeschaltet hab und die Soundkarte etwas produziert hat - weiß der Teufel was da aufgenommen wird - vielleicht Weltraumrauschen - aber nichts von der Soundkarte .... leider !!

    Freundliche Grüsse
    ZumbuschA
    google icon

    Wunderbar, dass Ihnen weiter geholfen werden konnte!

    Wir würden uns sehr freuen, wenn Sie uns eine Bewertung auf Google hinterlassen:
    Jetzt bewerten

    Die Antwort ist derzeit minimiert Show
  • Akzeptierte Antwort

    20:15, 26. Januar 2020
    ... ich habe auch rechts die beiden Vorgaben ohne Balken abgeändert -z.B. beides auf FrontMic und habe dann nochmal alle angebotenen Eingänge mit FrontMicrofon aufgerufen - leider ohne Ergebnis.

    .... die Pegel schlagen aus ohne dass Musik läuft und später ist nur Rauschen das Ergebnis.

    Ich habe auch Audacity mal selbst nach Sound suchen lassen - aber es wurde nichts gefunden obwohl Musik über die Soundkarte läuft ....

    Freundliche Grüsse
    ZumbuschA
    google icon

    Wunderbar, dass Ihnen weiter geholfen werden konnte!

    Wir würden uns sehr freuen, wenn Sie uns eine Bewertung auf Google hinterlassen:
    Jetzt bewerten

    Die Antwort ist derzeit minimiert Show
  • Akzeptierte Antwort

    19:27, 27. Januar 2020
    Hallo ZumbuschA,

    verstehe ich Sie richtig: Sie haben gar kein Mikrofon angeschlossen, sondern wollen Musik aufnehmen, die der Rechner selbst abspielt? Da haben wir etwas aneinander vorbei geredet.

    Da muss zuerst der PulseAudio Lautstärkeregler über Ubuntu Software installiert werden. Danach diesen und Audacity öffnen.

    Nun in Audacity auf das Mikrofonsymbol im Werkzeugbereich klicken und Start Monitoring auswählen. Jetzt die Aufnahme starten, kann danach gelöscht werden. Aber sie muss laufen für den nächsten Schritt.

    Nun den PulseAudio Lautstärkeregler auswählen und auf das Register Aufnahme gehen. Hier wird immer nur angezeigt, was gerade aufgenommen wird, deshalb muss Audacity aufnehmen. Es erscheint ALSA plug-in [audacity] von Eingebautes Tongerät Analog Stereo, letzteres muss auf Monitor of Eingebautes Tongerät Analog Stereo geändert werden. Sie sehen es auf dem Bild.

    Das Rauschen was Sie hören sind die voll aufgedrehten Pegel, das ist ein statisches Rauschen auch erzeugt von CPU und GPU. Daher sollten Sie im ALSAmixer die Pegel wieder etwas runter drehen.

    Mit freundlichen Grüßen
    Dirk Kleemann
    Anhänge:
    google icon

    Wunderbar, dass Ihnen weiter geholfen werden konnte!

    Wir würden uns sehr freuen, wenn Sie uns eine Bewertung auf Google hinterlassen:
    Jetzt bewerten

    Die Antwort ist derzeit minimiert Show
  • Akzeptierte Antwort

    20:03, 27. Januar 2020
    Hallo Herr Kleemann,

    meine Frage war von Anfang an so gestellt dass ich das aufnehmen möchte was über die Soundkarte zu hören ist z.B. von Musik aus dem WEB - von Mikrofonaufnahme hab ich nichts geschrieben und wir haben wohl wirklich aneinander vorbei geredet ... :o - aber kein Problem !!

    Die Pegel sind natürlich längst heruntergedreht (siehe die Fotos meiner vorherigen Antwort)

    Der PulseAudio Lautstärkeregler ist hier schon länger installiert.

    Bei Audacity und Anklicken des Mikrofon-Symbols gibt es keine Auswahl Start Monitoring. Es gibt die Auswahl Optionen (Foto 1) und "Überwachung starten" - ich nehme fast an dass das Gleiche ist wie das Monitoring.


    Wenn ich Überwachung starten anklicke schlagen die Pegel sofort aus (Musik läuft allerdings nicht - wieso die Pegel sich bewegen ist mir nicht klar).

    Dann wurde "Aufnahme" angeklickt .

    Wenn ich nun den Lautstärkeregler aufrufe und Aufnahme auswähle wird die Meldung angezeigt "Keine Applikation nimmt zur Zeit Ton auf" - und das obwohl die Pegel so weit ausschlagen dass sie fast rechts aus dem Bildschirm herausragen.. siehe Foto 4

    Unten ist "All streams" ausgewählt bei dem was angezeigt werden soll - bei der Auswahl
    "Applications" oder "Virtual streams" passiert auch nichts.

    Was bei dem Button "Eingabegeräte" angezeigt wird ist auf dem nächsten Foto zu sehen.

    Sie schreiben: Hier wird immer nur angezeigt, was gerade aufgenommen wird, deshalb muss Audacity aufnehmen ... da liegt aber das Problem - Audacity scheint überhaupt nichts aufzunehmen außer Rauschen ...

    Aber selbst die Aufnahme des Rauschens die ja schließlich abgehört werden kann wird vom Lautstärkeregler nicht als Aufnahme angezeigt.

    Freundliche Grüsse
    ZumbuschA
    google icon

    Wunderbar, dass Ihnen weiter geholfen werden konnte!

    Wir würden uns sehr freuen, wenn Sie uns eine Bewertung auf Google hinterlassen:
    Jetzt bewerten

    Die Antwort ist derzeit minimiert Show
  • Akzeptierte Antwort

    noha
    VIP
    noha
    online
    21:26, 27. Januar 2020
    Hallo Herr Zumbusch,

    um Ton von einer Anwendung (z.B. Browser mit youtube) zu einer anderen Anwendung (Audacity) zu übertragen, benötigen Sie eine virtuelle Soundkarte, engl. loop back device.
    Siehe https://wiki.ubuntu.com/record_system_sound

    Eine schlechte Alternative wäre ein Kabel, das den Ausgang der real vorhandenen Soundkarte mit ihrem Eingang verbindet. Zusätzlich müsste die Mithörfunktion (falls vorhanden) abgeschaltet werden.

    VG
    noha (der sich eigentlich nicht einmischen wollte)
    google icon

    Wunderbar, dass Ihnen weiter geholfen werden konnte!

    Wir würden uns sehr freuen, wenn Sie uns eine Bewertung auf Google hinterlassen:
    Jetzt bewerten

    Die Antwort ist derzeit minimiert Show
  • Akzeptierte Antwort

    21:41, 27. Januar 2020
    Hallo Noha

    vielen Dank für die Einmischung ... :) Ich bin für jede Hilfe dankbar!!!

    ..ich werde es mir ansehen - da ich des Englischen nicht sehr mächtig bin wird es etwas dauern ... ;)

    ... das Pulse Audio System hab ich übrigens schon auf dem Rechner... wenn ich im Terminal den Befehl eingebe "rm -r ~/.config/pulse; pulseaudio -k " passiert nichts außer daß die Musikwiedergabe von youtube aufhört ...

    ich habe eben auch pavucontrol installiert.

    ...kann man damit was anfangen oder was muß ich noch ändern oder installieren ?

    Wenn Musik über die Soundkarte läuft reagiert übrigens der Monitor of Audio Adapter ... (siehe Foto) wobei ich nicht weiß ob das was zu bedeuten hat ...



    Freundliche Grüsse
    ZumbuschA
    google icon

    Wunderbar, dass Ihnen weiter geholfen werden konnte!

    Wir würden uns sehr freuen, wenn Sie uns eine Bewertung auf Google hinterlassen:
    Jetzt bewerten

    Die Antwort ist derzeit minimiert Show
  • Akzeptierte Antwort

    18:02, 28. Januar 2020
    Hallo ZumbuschA,

    Sie haben schon richtig übersetzt, ich verstehe bei mir Audacity nicht ganz. Die Bilder sind vom Testsystem mit Ubuntu 18.04. Auf meinem Notebook verwende ich 19.10 und da ist es komplett englisch, obwohl bei beidem die Systemsprache verwendet werden sollte und alle anderen Programme komplett übersetzt sind. Ich hoffe wir kommen damit hin, mir fehlt gerade die zeit ein neues System aufzusetzen oder den Fehler zu finden.

    Was noha so schreibt war früher mal richtig, mittlerweile können die Soundkarten über die von mir beschriebene Monitoringfunktion direkt aufnehmen, was sie wiedergeben.

    Wenn ich mir Ihr Bild von Audacity aus der vorletzten Antwort ansehe, fällt mir auf das Sie den Aufnahmeknopf (der rote kreis) nicht gedrückt haben. Das meinte ich mit Aufnahme starten, nur wenn dies aktiv ist, zeigt der Pulseaudio Lautstärkemixer das Device an.

    Wenn Sie dann das Plugin wie ich beschrieben habe auf Monitor of Eingebautes Tongerät Analog Stereo geändert haben, können Sie die Aufnahme beenden und die gewünschte starten.

    Diese Einstellung sollte bis zur Änderung bzw. zum Neustart des Systems erhalten bleiben.

    Mit freundlichen Grüßen
    Dirk Kleemann
    google icon

    Wunderbar, dass Ihnen weiter geholfen werden konnte!

    Wir würden uns sehr freuen, wenn Sie uns eine Bewertung auf Google hinterlassen:
    Jetzt bewerten

    Die Antwort ist derzeit minimiert Show
  • Akzeptierte Antwort

    19:55, 28. Januar 2020
    Herr Kleemann,

    ... ich glaube jetzt unterschätzen Sie mich ein wenig ... :) Ich will doch sehr hoffen dass Sie das nicht ernst meinen dass ich möglicherweise nicht weiß was "Aufnahme starten" bedeutet .....

    Natürlich hatte ich den Aufnahmeknopf gedrückt nachdem ich die Überwachung gestartet hatte. Und die Anzeige im Lautstärkeregler nach dem Starten der Aufnahme hatte ich als Foto beigefügt.


    Das Foto von Audacity sollte zeigen wie die Pegel verrückt spielen und eine Aufnahme anzeigen die überhaupt nicht stattfindet. Ich hatte auch einen Verweis auf das Foto in meinem Text !!

    Und da der Lautstärkeregler nichts anzeigt habe ich auch keine Möglichkeit da etwas zu ändern. Das ist schade, ist aber so.

    Ich hatte auch die einzelnen Schritte die ich vorgenommen hatte genau beschrieben !!!

    Das von Ihnen angesprochene Foto 4 gehört zu diesem Text:

    Wenn ich Überwachung starten anklicke schlagen die Pegel sofort aus (Musik läuft allerdings nicht - wieso die Pegel sich bewegen ist mir nicht klar).

    Dann wurde "Aufnahme" angeklickt .

    Wenn ich nun den Lautstärkeregler aufrufe und Aufnahme auswähle wird die Meldung angezeigt "Keine Applikation nimmt zur Zeit Ton auf" - und das obwohl die Pegel so weit ausschlagen dass sie fast rechts aus dem Bildschirm herausragen.. siehe Foto 4


    Freundliche Grüsse
    ZumbuschA
    google icon

    Wunderbar, dass Ihnen weiter geholfen werden konnte!

    Wir würden uns sehr freuen, wenn Sie uns eine Bewertung auf Google hinterlassen:
    Jetzt bewerten

    Die Antwort ist derzeit minimiert Show
  • Akzeptierte Antwort

    noha
    VIP
    noha
    online
    00:17, 29. Januar 2020
    Hallo Herr Zumbusch,

    Vorbemerkung: Ich verwende Audacity nicht, so dass es sein kann, dass das Folgende falsch ist.

    So weit ich weiß, bedeutet "Überwachung starten", dass Audacity den Pegel von dem zur Aufnahme gewählten Gerät beobachtet und, wenn ein vorher eingestellter Wert (=Lautstärke) überschritten wird, die dann Aufnahme startet.

    Egal mit welchem Programm bzw. Gerät Sie arbeiten:
    Wenn der Schwellwert für das Eingangssignal sehr niedrig ist und am ausgewählten Eingang kein Gerät angeschlossen ist, kann es sein, dass das Rauschen des unbenutzten Eingangs so stark ist, dass die Aufnahme startet.

    VG
    noha
    google icon

    Wunderbar, dass Ihnen weiter geholfen werden konnte!

    Wir würden uns sehr freuen, wenn Sie uns eine Bewertung auf Google hinterlassen:
    Jetzt bewerten

    Die Antwort ist derzeit minimiert Show
  • Akzeptierte Antwort

    14:07, 29. Januar 2020
    Hallo Noha,

    das was Sie schreiben klingt sehr plausibel und würde den Ausschlag der Pegel erklären sobald Überwachung angeklickt wird. Wobei die Pegel auch ausschlagen wenn Überwachung nicht aktiviert ist. Die von mir beeinflussbaren Aufnahmepegel sind im Alsamixer entsprechend auf Mittelwert eingestellt.

    Aber das Rauschen das Audacity wahrnimmt stammt vermutlich - wie Herr Kleemann früher mal geschrieben hat - durch die CPU


    Test:

    Ich habe den Alsamixer und Audacity aufgerufen.

    - Bei Audacity (Eingang steht auf "HDA ATI SB: ALC892.... Line 1" (kein Pegelausschlag)

    - Überwachung gestartet - Pegel schlagen gemäßigt aus bis -57

    - im Alsamixer den Input Source 1 (Rear Mic) steht die Auswahl rechts auf Line.

    - Beim Umstellen dort auf RearMic schlagen die Pegel weiter aus bis ca. -36

    - das Gleiche bei FrontMi

    - bei Veränderung bei Input source ((Line) links zeigen sich in Audacity keine Veränderungen, d.h. Ausschlag Pegel gemäßigt bis -57

    zu den anderen einstellbaren Balken Alsamixer:

    Runterfahren des Pegels bei Digital zeigt Audacity bei den Pegeln keine Veränderung.

    Bei "Capture 1" reagiert Audacity bei Veränderung (rechter Balken.

    Bei Veränderung des Reglers "Capture" links in Alsamixer reagiert Audacity bei den Pegelausschlägen nicht !!

    LineBoost steht auf 53 und eine Veränderung der Einstellung auf 0 oder 95 verändert den Pegelausschlag in Audacity nicht.
    Das Gleicht gilt bei Veränderung bei Balken ganz links (Frot Mic Boost) -= keine Reaktion in Audacity.

    Bei Veränderung von Rear Mic Boost (Balken Alsamixer ganz rechts) reagiert der Pegelausschlag von Audacity.

    Vielleicht hilft dies bei der weiteren Fehlersuche.

    Freundliche Grüsse
    ZumbuschA
    google icon

    Wunderbar, dass Ihnen weiter geholfen werden konnte!

    Wir würden uns sehr freuen, wenn Sie uns eine Bewertung auf Google hinterlassen:
    Jetzt bewerten

    Die Antwort ist derzeit minimiert Show
  • Akzeptierte Antwort

    17:16, 30. Januar 2020
    Hallo ZumbuschA,

    ich wollte Ihnen da nichts unterstellen. Ich versuche ja nur das Problem zu lösen. Mir ist auf dem Bild aufgefallen, das der Aufnahmeknopf in Ruheposition war. Und wenn das so ist, wird auch bei mir kein Device für die Aufnahme angezeigt, obwohl der Pegel ausschlägt. Ich versuche alle Fehler auszuschließen, schließlich sehe ich ja nicht was Sie genau machen. Deshalb frage ich lieber einmal mehr nach.

    Überwachung bedeutet hier, das in dem Monitor gezeigt wird, welcher Pegel auf diesem Gerät aufliegt,. Es hat nichts mit dem automatischen Start bei Überschreiten eines Pegels zu tun, wie man es von Chatprogrammen (beispielsweise Teamspeak) kennt. Das wäre das verhalten was noha beschreibt.

    Sämtliche mit Mic beschrifteten Aufnahmegräte interessieren Sie nicht, das war ja meine falsche Annahme. Mic steht immer für Microfon und Sie wollen ja das abgreifen was die Soundkarte erzeugt und das geht über ein cpature device (Monitor des eingebauten Audiogerätes).

    Im Alsamixer sehen Sie ja zwei Capturepegel, dies wird das interne Device sein. Allerdings ist hier der Pulseaudio Lautstärkeregeler wichtiger, da dieser von Audacity verwendet wird.

    Mit freundlichen Grüßen
    Dirk Kleemann
    google icon

    Wunderbar, dass Ihnen weiter geholfen werden konnte!

    Wir würden uns sehr freuen, wenn Sie uns eine Bewertung auf Google hinterlassen:
    Jetzt bewerten

    Die Antwort ist derzeit minimiert Show
  • Akzeptierte Antwort

    17:39, 30. Januar 2020
    Hallo Herr Kleemann,

    ich hatte halt die Idee mal mit Audycity und Alsamixer so ne Art Abgleich zu machen - aber kann man mit dem was ich gemacht habe gar nix anfangen? Welches ist der Pulseaudio-Regler im Alsamixer ?I

    Bei Wiedergabe taucht im Alsamixer ein Regler PCM auf - das könnte der Pulseaudio-Regler sein ? Aber wieso ist der bei der Aufnahme-Ansicht von Alsamixer nicht zu sehen?

    Was kann ich jetzt noch ausprobieren ?

    Freundliche Grüsse
    ZumbuschA
    google icon

    Wunderbar, dass Ihnen weiter geholfen werden konnte!

    Wir würden uns sehr freuen, wenn Sie uns eine Bewertung auf Google hinterlassen:
    Jetzt bewerten

    Die Antwort ist derzeit minimiert Show
  • Akzeptierte Antwort

    18:11, 30. Januar 2020
    Hallo Herr Kleemann,

    ich habe jetzt nochmals Audacity aufgerufen, das procedere mit Überwachung und Aufnahme durchgeführt.

    Audacity bietet momentan nur eine eingeschränkte Anzahl Eingänge an: 6 x HDA ATI SB, 6 x Pulse und 6 x Default.

    Es läuft im Hintergrund Musik über die Soundkarte.

    Die Pegel bewegen sich nicht - auch in Audacity ist nichts zu sehen von einer laufenden Aufnahme - aber im Lautstärkeregler wird nun erstmals (!!!) etwas angezeigt.

    Fotos sind beigefügt.

    Allerdings finde ich im Lautstärkeregler keine Möglichkeit die Änderung die Sie empfohlen hatten durchzuführen.

    Nun den PulseAudio Lautstärkeregler auswählen und auf das Register Aufnahme gehen. Hier wird immer nur angezeigt, was gerade aufgenommen wird, deshalb muss Audacity aufnehmen. Es erscheint ALSA plug-in [audacity] von Eingebautes Tongerät Analog Stereo, letzteres muss auf Monitor of Eingebautes Tongerät Analog Stereo geändert werden. Sie sehen es auf dem Bild.

    Wie kann ich die nötige Umstellung vornehmen?

    Freundliche Grüsse
    ZumbuschA
    google icon

    Wunderbar, dass Ihnen weiter geholfen werden konnte!

    Wir würden uns sehr freuen, wenn Sie uns eine Bewertung auf Google hinterlassen:
    Jetzt bewerten

    Die Antwort ist derzeit minimiert Show
  • Akzeptierte Antwort

    19:19, 30. Januar 2020
    Hallo ZumbuschA,

    Sowohl ALS als auch Pulseaudio sind zwei Soundserver für Linux. ALSA ist dabei die einfachste Art mit Sound umzugehen und auch im Standard Ubuntu vorhanden, es funktioniert unabhängig vom grafischen System.

    Puleseaudio ist bei Ubuntu auch immer dabei und der Standardserver des grafischen Systems.Es kann einfach deutlich mehr.

    Zum besseren Verständnis bei Muße einfach mal in die Grundlagen einlesen. Vielleicht fällt Ihnen dann etwas auf. Es ist halt schwer, den Fehler nachzuvollziehen, wenn ich ihn nicht nachstellen kann. Bei mir klappt es in jedem System auf Anhieb, zumindest so bald ich eine funktionierende Soundkarte habe.

    Der wichtig Pegel für Capture ist der neben dem Microfonsymbol, das allgemein für Aufnahme steht. Und dieser muss ausschlagen, wenn das Monitoring aktiv ist. Nur wenn dies der Fall ist, kann Pulseaudio etwas unter Aufnahme finden.

    Mit freundlichen Grüßen
    Dirk Kleemann
    google icon

    Wunderbar, dass Ihnen weiter geholfen werden konnte!

    Wir würden uns sehr freuen, wenn Sie uns eine Bewertung auf Google hinterlassen:
    Jetzt bewerten

    Die Antwort ist derzeit minimiert Show
  • Akzeptierte Antwort

    19:53, 30. Januar 2020
    Hallo Herr Kleemann,

    ich glaube fast dass bei der Installation von Audacity etwas schiefgelaufen ist.

    Wenn ich jetzt Audacity aufrufe werden wieder etliche Eingangs-Möglichkeiten aufgezeigt - jetzt sind es 12 x HDA ATI SB - wo es heute Mittag nur 6 waren.

    Und wenn ich jetzt auf Aufnahme drücke kommt die folgende Fehlermeldung - siehe Foto

    Freundliche Grüsse
    ZumbuschA
    google icon

    Wunderbar, dass Ihnen weiter geholfen werden konnte!

    Wir würden uns sehr freuen, wenn Sie uns eine Bewertung auf Google hinterlassen:
    Jetzt bewerten

    Die Antwort ist derzeit minimiert Show
  • Akzeptierte Antwort

    17:33, 31. Januar 2020
    Hallo ZumbuschA,

    an Audacity selbst wird es nicht liegen, das ist ja nur ein Paket was automatisch installiert wird. Aber Sie haben das System ja schon länger und wenn ich mich recht erinnere, haben Sie auch ein Update von 16.04 auf 18.04 gemacht, was eine sehr schlechte Idee ist.Ich vermute da haben sich viele Problem eingeschlichen die nun nach und nach auffallen.

    Auch wenn es bis zu diesem Zeitpunkt viel Mühe war, ist eine Neuinstallation vermutlich das sinnvollste, um einmal mit einem sauberen System anzufangen. In dem Fall überlegen, was jetzt in den letzten Wochen alles erfolgreich war und sich die passenden Dinge raussuchen und die Fehlversuche vergessen. So ist der Stand von jetzt mit einem sauberen System sicher schnell erreicht.

    Ich kann verstehen wenn Sie das nicht wollen, dann machen wir weiter und versuchen die Probleme zu lösen. Ich sehe nur wie sich das immer länger hin zieht, viel probiert wird und dadurch einiges geändert wird und man den Überblick verliert.

    Einmal den Neuanfang und das gelernte gleich richtig umsetzen würde vermutlich schneller zum besseren Ergebnis führen. Aber das ist sicherlich auch meine Mentalität, ich mache dann mal schnell nen Schnitt und fange von vorne an. Wie gesagt ihre Entscheidung.

    Mit freundlichen Grüßen
    Dirk Kleemann
    google icon

    Wunderbar, dass Ihnen weiter geholfen werden konnte!

    Wir würden uns sehr freuen, wenn Sie uns eine Bewertung auf Google hinterlassen:
    Jetzt bewerten

    Die Antwort ist derzeit minimiert Show
  • Akzeptierte Antwort

    18:45, 31. Januar 2020
    Hallo Herr Kleemann,

    Sie haben völlig Recht - ich selbst habe mir das auch schon überlegt - aber bei der Aktualisierung auf 18.04 hätte ich mit solchen Problem nicht gerechnet ... aber so sehr viel Arbeit ist es ja nicht - die wichtigen Dateien auf z.B. die USB-Festplatte beamen und auf einer anderen freien Partition eine "saubere" Version von 18.04 neu installieren.

    Auf meinem ersten pc ist das windows regelmäßig abgestürzt und da habe ich alles mehr als ein Mal neu installieren müssen - da kriegt man dann auch Routine drin. :)

    Ich bin an sich ein großer Fan von Improvisation aber in einigen Bereichen muß es einfach reibungslos funktionieren - diese ständige Rumschrauberei nervt auch mich so langsam weil immer wieder etwas nicht richtig funktioniert und - wie jetzt bei Audacitiy - mit noch so viel Mühe (auch von Ihnen) die Ursachen nicht wirklich zu finden sind.

    Ich glaube dass ich das in allernächster Zeit machen werde.

    Freundliche Grüsse
    ZumbuschA
    google icon

    Wunderbar, dass Ihnen weiter geholfen werden konnte!

    Wir würden uns sehr freuen, wenn Sie uns eine Bewertung auf Google hinterlassen:
    Jetzt bewerten

    Die Antwort ist derzeit minimiert Show
  • Akzeptierte Antwort

    17:58, 24. Februar 2020
    Hallo Herr Kleemann,

    das neue "saubere" Ubuntu 18.04 ist installiert. Audacity ebenfalls - aber mit der Aufnahme klappt es noch nicht.

    Ich bin die Schritte die Sie früher schon empfohlen haben soweit durchgegangen.

    "Nun den PulseAudio Lautstärkeregler auswählen und auf das Register Aufnahme gehen. Hier wird immer nur angezeigt, was gerade aufgenommen wird, deshalb muss Audacity aufnehmen. Es erscheint ALSA plug-in [audacity] von Eingebautes Tongerät Analog Stereo, letzteres muss auf Monitor of Eingebautes Tongerät Analog Stereo geändert werden". . = ist eingestellt (siehe Foto).

    Bei "Aufnahme" startet die Pegelanzeige - beim Abspielen ebenfalls aber es ist nichts zu hören. Ausgang steht auf "pulse".

    Mit dem jetzigen Ubuntu sollten wir das Problem sicher lösen können.

    Freundliche Grüsse
    ZumbuschA
    google icon

    Wunderbar, dass Ihnen weiter geholfen werden konnte!

    Wir würden uns sehr freuen, wenn Sie uns eine Bewertung auf Google hinterlassen:
    Jetzt bewerten

    Die Antwort ist derzeit minimiert Show
  • Akzeptierte Antwort

    noha
    VIP
    noha
    online
    10:49, 25. Februar 2020
    Hallo Herr Zumbusch,

    ich gehe mal die Bilder durch:
    1. In Audacity ist als Aufnahmegerät ein Mikrofon eingestellt, das an der Rückseite des Rechners angeschlossen wird.
    2. Bild 2: OK
    3. Bild 3: OK
    4. Bild 4: Hier sind 3 Quellen aktiv, sinnvoll ist aber nur die mit "Capture" bezeichnete. Der ebenfalls aktive Mikrofoneingang ganz rechts sorgt für das starke Rauschen, das Audacity aufnimmt, denn dieses Gerät haben Sie in 1 ja gewählt.
    5. Bild 6: hier ist anstelle des an der Rückseite aktiven Mikrofoneingang der auf der Frontseite gewählt.

    Bietet Audacity an, als Quelle "Capture" zu verwenden?

    Mein alter Spruch:
    Rechner sind dumm und machen genau das, was der Anwender eingibt. Das ist aber oft nicht das, was er will.

    VG
    noha
    google icon

    Wunderbar, dass Ihnen weiter geholfen werden konnte!

    Wir würden uns sehr freuen, wenn Sie uns eine Bewertung auf Google hinterlassen:
    Jetzt bewerten

    Die Antwort ist derzeit minimiert Show
  • Akzeptierte Antwort

    14:44, 25. Februar 2020
    Beitrag wurde versehentlich 2 mal hochgeladen - und Löschen einer Antwort ist offensichtlich nicht möglich... :o
    google icon

    Wunderbar, dass Ihnen weiter geholfen werden konnte!

    Wir würden uns sehr freuen, wenn Sie uns eine Bewertung auf Google hinterlassen:
    Jetzt bewerten

    Die Antwort ist derzeit minimiert Show
  • Akzeptierte Antwort

    14:49, 25. Februar 2020
    Hallo Noha,

    zu 1: Das Foto bezog sich aufs Abspielen - um zu zeigen dass Audacity unter "pulse" etwas abspielt - Sie haben völlig Recht - auf Mikrofon einzustellen und dann darauf zu warten dass die Soundkarte etwas von z.B. aus dem Web abgespielter Musik nach Audacity transportiert wäre sicher nicht erfolgreich. :-) .... aber ich habe aus Verzweiflung halt alle angebotenen Möglichkeiten ausprobiert da die, von denen ich mir was erhofft hatte, nicht funktioniert hatten ....

    Zu 4 und 5: Den Mikrofoneingang ganz rechts habe ich runtergeregelt - das sollte also keine Quelle mehr für Rauschen sein. Die Regler im Alsamixer sind für Capture beide hochgefahren. (Anwahl ist jedoch nur für jeweils einen Regler möglich)

    Audacity bietet für Aufnahme leider Capture nicht an (siehe Fotos aller angebotenen Möglichkeiten)

    Freundliche Grüsse
    ZumbuschA
    google icon

    Wunderbar, dass Ihnen weiter geholfen werden konnte!

    Wir würden uns sehr freuen, wenn Sie uns eine Bewertung auf Google hinterlassen:
    Jetzt bewerten

    Die Antwort ist derzeit minimiert Show
  • Akzeptierte Antwort

    noha
    VIP
    noha
    online
    17:22, 25. Februar 2020
    Hallo Herr Zumbusch,

    vorweg: ich benutze Audacity nicht. Ich verwende Adobe Audition in Windows XP für Audio-Bearbeitung und für die Aufnahme Reaper in Windows 10.

    Wenn Sie den Alsa-Mixer verwenden, sollten Sie diesen auch als Quelle für die Aufnahme in Audacity wählen - gut, geht bei Ihnen nicht - oder ist das Pulse-Audio? Wenn Sie statt dessen eine Quelle in Audacity wählen, sollte es egal sein, was Sie im Mixer eingestellt haben.

    VG
    noha
    google icon

    Wunderbar, dass Ihnen weiter geholfen werden konnte!

    Wir würden uns sehr freuen, wenn Sie uns eine Bewertung auf Google hinterlassen:
    Jetzt bewerten

    Die Antwort ist derzeit minimiert Show
  • Akzeptierte Antwort

    17:42, 25. Februar 2020
    Hallo ZumbuschA,

    lassen Sie den Alasamixer erst mal in Ruhe, der wird hier nicht benötigt.

    Wichtig ist immer noch in Audacity auf das Microfonsymbol zu klicken und dann Start Monitoring auszuwählen. und die Aufnahme für den Test zu starten.

    Dann den PluseAudio Lautstärkeregler starten und im Register Aufnahme überprüfen, das das ALSA plug-in [audacity] erscheint. Das sehen wir auf Ihrem Bild. Nur das Pulldownmenü steht bei ihnen auf Eingebautes Tongerät Analog Stereo, das wäre ein Microfon. Sie müssen dies auf Monitor of Eimngebautes Tongerät Analog Stereo stellen.

    Mit freundlichen Grüßen
    Dirk Kleemann
    google icon

    Wunderbar, dass Ihnen weiter geholfen werden konnte!

    Wir würden uns sehr freuen, wenn Sie uns eine Bewertung auf Google hinterlassen:
    Jetzt bewerten

    Die Antwort ist derzeit minimiert Show
Login Bild

Bitte melden Sie sich an um eine Antwort zu verfassen

Sie müssen angemeldet sein um eine Antwort zu verfassen. Sie können hierfür das Anmeldeformular rechts nutzen oder sich registrieren.

Hier registrieren »