1. dietergausk VIP
  2. Linux
  3. Freitag, 30. April 2021
Der grafische Desktop (GNOME ?) erscheint nicht beim Starten meines Ubuntu-Laptops. Nur ein blinkender Cursor auf einem sonst leeren Bildschirm ist nach einem Neustart sichtbar. Mit meinen rudimentären Kenntnissen vom Raspberry Pi gelingt es mir, per Eingabe von Strg-Alt-F2 ein zweites Terminal zu öffnen, wo ich mich dort als User und mit Passwort anmelden konnte. Mit der Eingabe von startx bekam ich dann auch die grafische Oberfläche zu sehen.

Wie kann ich erreichen, dass ich sofort und automatisch auf der grafischen Benutzeroberfläche lande?

Beste Grüße

Dieter G. aus K.
Antworten (8)
Akzeptierte Antwort Pending Moderation
Hallo dietergausk

zum Thema "blinkender Cursor" lesen Sie bitte mal diesen Forenbeitrag:
https://club.computerwissen.de/qa/51727-startproblem-ubuntu-linux-16-04
Evtl. helfen Ihnen die dort erwähnten Probleme: Secure Boot, Grafikkarte (Nvidia), .... schon ein Stück weiter.

MfG
Li
Webinar Bild

Schön, dass Ihre Frage beantwortet wurde!

Um weiterhin auf dem Laufenden zum Thema Technik und PC zu bleiben, nehmen Sie doch kostenlos teil an unseren monatlichen LIVE-Webinaren: hier klicken für Registrierungsseite. Bei diesen Online-Shows können Sie uns all Ihre Fragen rund um das Thema Computer stellen und lernen jeden Monat etwas Neues.

  1. vor einer Woche
  2. Linux
  3. # 1 1
Akzeptierte Antwort Pending Moderation
Guten Morgen Herr Lippmann,

vielen Dank für Ihre promte Antwort.

Ihrem Rat bin ich gefolgt und habe mir den o.g. Forenbeitrag angesehen. Das hat nun neue Fragen aufgeworfen: Wo finde ich das "Secure Boot"? Wie kann ich das deaktivieren?

Warum kann ich, wenn ich ein zweites Terminal starte, in die grafische Oberfläche mit "startx" gelangen? Das ist doch ein Beleg dafür, dass der Treiber für die Grafikkarte der richtige ist und auch richtig arbeitet. Das Problem scheint woanders zu liegen.

MfG, Dieter G. aus K.
Webinar Bild

Schön, dass Ihre Frage beantwortet wurde!

Um weiterhin auf dem Laufenden zum Thema Technik und PC zu bleiben, nehmen Sie doch kostenlos teil an unseren monatlichen LIVE-Webinaren: hier klicken für Registrierungsseite. Bei diesen Online-Shows können Sie uns all Ihre Fragen rund um das Thema Computer stellen und lernen jeden Monat etwas Neues.

  1. vor einer Woche
  2. Linux
  3. # 1 2
Akzeptierte Antwort Pending Moderation
Hallo Dieter G. aus K.,

wenn die grafische Oberfläche aus der Konsole heraus startet, dürfte es an fehlerhaften Einträgen im Startvorgang liegen oder das Benutzerprofil macht Probleme.

Wissen Sie noch was Sie gemacht haben, bevor das Problem auftrat oder war dies direkt nach der Installation?

Wichtig wären vor allem Updates und Treiberinstallationen sowie neue Prorgamme.

Hilfreich wäre auch die verwendete Distribution.

Mit freundlichen Grüßen
Dirk Kleemann
Webinar Bild

Schön, dass Ihre Frage beantwortet wurde!

Um weiterhin auf dem Laufenden zum Thema Technik und PC zu bleiben, nehmen Sie doch kostenlos teil an unseren monatlichen LIVE-Webinaren: hier klicken für Registrierungsseite. Bei diesen Online-Shows können Sie uns all Ihre Fragen rund um das Thema Computer stellen und lernen jeden Monat etwas Neues.

  1. vor einer Woche
  2. Linux
  3. # 1 3
Akzeptierte Antwort Pending Moderation
Hallo Herr Kleemann,

vielen Dank, dass Sie mit mir nach einer Lösung suchen.

Das Problem mit der fehlenden grafischen Oberfläche besteht seit Anbeginn der Erstinstallation von Ubuntu.

Nachfolgend zeige ich Ihnen Teile meiner Aufzeichnungen, die ich mir während der Installation gemacht hatte:

Stand: 23.04.2021

Auf meinem altem Dell Windows-Vista bzw. hochgerüstetem Windows 7 hatte ich Linux-Mint leider nicht zum Laufen gebracht. Darum nun der Versuch, Ubuntu darauf zu installieren. Ein USB-Ubuntu-ISO war schnell erstellt (gem. der Computerwissen Anleitung; Screenshot siehe Bild im Anhang)

Es ist mir sogar gelungen, das Ubuntu-Betriebssystem auf dem Dell-Laptop zu konfigurieren und zu installieren. Das Windows-7-Betriebssystem wurde dabei vollständig gelöscht. Leider konnte Ubuntu nach einem notwendigen Neustarten des Rechners nicht starten. Es scheint, dass die BIOS-Routinen nun hakeln. Ob es am Ubuntu oder am Starten von USB-Stick liegt weiss ich nicht. Es erscheinen kurz eingeblendete Fehler aus/über BIOS.

Ich prüfe erst einmal, ob ich ein aktuelles BIOS auf dem Rechner habe. Mit F2 starte ich das PhoenixBIOS Setup. Version 2.6.3 wird mir auf dem Dell Inspiron 1501 Laptop angezeigt. Die Infos aus den diversen Foren bestätigen, dass die BIOS-Version 2.6.3 die aktuelle ist. Der eingebaute AMD semprion Processor 3500+ und die anderen Komponenten stellen ein 64 Bit-System dar.


Stand: 24.04.2021

Heute stelle ich beim Hochfahren des Ubuntu-Laptops fest, dass zwar die oben beschriebene Fehlermeldung z.B MPI-Bios-time error MP-BIOS_Bug 8254 not connected to IO-APIC kurz aufblitzt (wie kann ich erreichen, dass die Meldungen Schritt für Schritt erscheinen oder eine Stop/Pause-Taste wirksam wird, um nachlesen zu können, was das System beim Hochfahren so alles meldet?) und Ubuntu irgendwas im Hintergrund macht, um dann mit einem blinkenden Cursor (Unterstrich) stehen zu bleiben. Leider gibt es keine grafische Oberfläche zu sehen und Eingaben sind auch nicht möglich (es gibt keinerlei Reaktionen vom System).

Im Ubunto-Forum entdecke ich den Hinweis, dass man mit Strg-Alt-F2 in ein zweites Terminal-Fenster gelangen kann. Tatsächlich – Es meldet sich Ubuntu 20.04.2 LTS Dell-Inspiron-1501 tty2 mit der vom Raspbian-OS bekannten Anmeldeprozedur. Das Login mit meinem Benutzernamen dieter und der Eingabe meines Passwortes x...x ist schnell erledigt.
Hurra, Ubuntu meldet sich auf der Konsole erstmalig mit:

Welcome to Ubuntu 20.04.2 LTS (GNU/Linux 5.8.0-43-generic x86_64) und abschließend mit dem für Linux üblichen Eingabe-Promt: dieter@Dell-Inspiron-1501:~$

Mit einem ersten Kommando pwd und ls -la prüfe ich, ob Linux meine Befehle erkennt und entsprechende Antworten gibt. Ja, es klappt. Nun mache ich mich im Internet auf die Suche nach Lösungen um auch beim Starten von Ubuntu direkt auf die grafische Oberfläche zu gelangen (dazu nutze ich noch meinen anderen Windows 10 Rechner).

Ein Ubuntu-User schreibt, dass der neueste Linux-Kernel 5.8.x alte Grafikkarten nicht unterstützt. Er musste wieder zurück nach Kernelversion 5.4.x.

Mit sudo more /var/log/boot.log lese ich seitenweise die Logdatei des Bootvorgangs aus. Die Einträge dort beginnen am heutigen 24.04.2021 um 14:30:23 Uhr CEST (Central Europe Summer Time). Mir fällt diese Aufzeichnung auf: Mounting /boot/efi… und anschließend Mounted /boot/efi. Ferner sehe ich diesen letzten Eintrag bevor die nächste Session aufgezeichnet wird:
Started GNOME Display Manager. So scheint es, dass die grafische Oberfläche GNOME gestartet wurde.

Auf das Kommando sudo apt-get install gnome-shell kommt die Antwort

gnome-shell is already the newest version (3.36.4-1ubuntu~20.04.2) (in den Settings wird sogar die Versions-Nr. 3.36.8 angezeigt).

Die Eingabe von startx lässt das Konsolenfenster verschwinden. Es erscheint die grafische Oberfläche von Ubuntu (braun-violetter Hintergrund) mit der obersten Zeile „Activities – Update-notifier – Aktuelles Datum / Uhrzeit – Symbole für Lautsprecher und Batterie und einen nach unten gerichteten „Options-Pfeil“. Dahinter verbirgt sich ein Menü mit

• Schieberegler für die Lautsprecher,
• Schieberegler für die Bildschirmhelligkeit
• Batteriestatus
• Settings (Einstellungen)
• Lock (Sperren des Rechners)
• Power Off / Log Out

Ein Fenster mit „Welcome“-Überschrift erscheint. Nach einiger Zeit kommt noch die Meldung „System program problem detected“, was ich mit cancel ignoriere. Nach der Eingabe von einigen Einstellungen (z.B. deutsche Tastatur) erscheint der Button „Start Using Ubuntu“.

Juhu! Der Ubuntu-Desktop erscheint.

Beim Stöbern finde ich unter dem Menüpunkt settings unter den Einstellungen von Network die

Hardware-Adresse des Laptops: uu:vv:ww:xx:yy:zz


Stand: 25.04.2021

Unter Settings – About werden mir einige Daten des Laptops angezeigt, u.a.:

• Memory 853,4 MB
• Processor Mobile AMD Sempron processor 3500+
• Disk Capacity 80,0 GB
• OS Name Ubuntu 20.04.2 LTS
• OS Type 64-bit
• GNOME Version 3.36.8
• Windows System X11

Um u.a. das deutsche Sprachpaket und auch den Treiber für das WLAN-Interface aus dem Internet herunterladen zu können, stelle ich eine Ethernet-Kabel-Verbindung mit der FRITZ!Box her. In der ganz oben befindlichen Menüleiste erschein nun auch das Symbol für das draht-gestützte Netzwerk. In den Settings – Network erscheint nun auch unter Wired die Angabe Connected – 100 Mb/s. Unter Details werden diese Angaben aufgelistet:

• Link speed 100 Mb/s
• IPv4 Address 192.168.xxx.yy
• IPv6 Address fexx::9yyy:3zzz:buuu:cwww
• Hardware Address uu:vv:ww:xx:yy:zz
• Default Route 192.168.xxx.y
• DNS 192.168.xxx.y

Connect automatically, ja

Make available to other users, ja

Das sind ja schon mal wieder gute Aussichten.

Das deutsche Sprachpaket wurde über die bestehende Internetverbindung heruntergeladen und installiert. Ein Neustart des Rechners ist erforderlich.

Leider startet Ubuntu immer noch nicht automatisch mit der grafischen Oberfläche. Gemäß den oben beschriebenen Eingaben gelange ich über das Terminal und mit der Eingabe von startx auf die grafische Oberfläche von Ubuntu. Es zeigt sich sogar alles in deutscher Sprache.

Um die Lautsprecher zu testen lade ich mir Spotify aus dem UbuntuStore herunter, installiere dieses und starte es auch sogleich. Wegen nicht mehr gültigen Benutzernamen/Passwort konnte ich Spotify nicht starten. Dafür habe ich dann den standardmäßig vorhandenen Musikabspieler Rhythmbox gestartet und einen Internet-Radiosender (Radio Paradise) gestartet. Ich höre Musik aus den Lautsprechern. Es funktioniert!

Ich hoffe, obige Angaben sind sehr hilfreich und Ihnen fallen noch einige Dinge ein, die dann endlich den grafischen Bildschirm schon beim morgentlichen Starten des Laptops erscheinen lassen.

Nochmals vielen Dank für Ihre uneigennützige Unterstützung.

MfG, Dieter G. aus K.


Rufus-Ubuntu-ISO-Image.png
Anhänge
Webinar Bild

Schön, dass Ihre Frage beantwortet wurde!

Um weiterhin auf dem Laufenden zum Thema Technik und PC zu bleiben, nehmen Sie doch kostenlos teil an unseren monatlichen LIVE-Webinaren: hier klicken für Registrierungsseite. Bei diesen Online-Shows können Sie uns all Ihre Fragen rund um das Thema Computer stellen und lernen jeden Monat etwas Neues.

  1. vor einer Woche
  2. Linux
  3. # 1 4
noha
VIP
Akzeptierte Antwort Pending Moderation
Hallo Dieter,

dass Sie auf dem ersten Bildschirm nichts eingeben können, liegt daran, dass es das Log-Fenster ist. Dessen Ausgabe können Sie (vielleicht) mit der Pause-Taste anhalten.

Was mir unklar ist, ist dass die Info-Seite nur 853,4 MB Hauptspeicher anzeigt. Kann es sein, dass der Rechner nur 1 GB Hauptspeicher hat und der hier fehlende Platz von der Grafikkarte benutzt wird?

"Secure Boot" müssen Sie wohl nicht länger suchen, weil Ihr Rechner dafür zu alt ist.

VG
noha
Webinar Bild

Schön, dass Ihre Frage beantwortet wurde!

Um weiterhin auf dem Laufenden zum Thema Technik und PC zu bleiben, nehmen Sie doch kostenlos teil an unseren monatlichen LIVE-Webinaren: hier klicken für Registrierungsseite. Bei diesen Online-Shows können Sie uns all Ihre Fragen rund um das Thema Computer stellen und lernen jeden Monat etwas Neues.

  1. vor einer Woche
  2. Linux
  3. # 1 5
Akzeptierte Antwort Pending Moderation
Hallo Dieter G. aus K.,

der geringe Hauptspeicher erklärt natürlich wieso das System nicht sauber startet. Ich wundere mich, das Sie es installieren konnten. Ubuntu benötigt mindestens 2 GB Arbeitsspeicher. Rechner mit weniger sollten mit Xubuntu oder Lubuntu betrieben werden. Die beiden Desktops sind deutlich Ressourcen schonender.

Das Sie das grafische System aus der Konsole starten können, lässt sich dadurch erklären, das dann die Auslagerungedatei bereit ist und Teile des Systems direkt dort landen.

Installieren Sie lieber eine der schlankeren Ubuntuversionen.

Mit freundlichen Grüßen
Dirk Kleemann
Webinar Bild

Schön, dass Ihre Frage beantwortet wurde!

Um weiterhin auf dem Laufenden zum Thema Technik und PC zu bleiben, nehmen Sie doch kostenlos teil an unseren monatlichen LIVE-Webinaren: hier klicken für Registrierungsseite. Bei diesen Online-Shows können Sie uns all Ihre Fragen rund um das Thema Computer stellen und lernen jeden Monat etwas Neues.

  1. vor einer Woche
  2. Linux
  3. # 1 6
Akzeptierte Antwort Pending Moderation
Hallo noah,

Danke für die Mithilfe. Das Betätigen der Pause-Taste hatte leider nicht die erhoffte Wirkung gezeigt. Ich bin mir allerdings nicht sicher, zu welchem Zeitpunkt man die Pause-Taste hätte drücken müssen. Ich hatte noch vor der Login-Prozedur diese Taste gedrückt.

Ihre Vermutung ist richtig; der Dell-Rechner hat nur 1 GB RAM. Arbeite ich im zweiten Terminal (auf der grafischen Oberfläche), so bin ich mit der Geschwindigkeit des Rechners zufrieden. Für die Programmieraufgaben meiner Enkelkinder reicht das allemal. Ob dieser Rechner einen Teil seines Hauptspeichers der Grafikkarte abtreten muss, entzieht sich meiner Kenntnis. Ich dachte immer, eine Grafikkarte bringt seinen eigenen und deutlich schnelleren Speicher mit. Nur von meinem Raspberry Pi kenne ich die Eigenschaft, dass für die GPU ein Teil des Hauptspeichers abgetreten werden muss (was man dort in den Einstellungen auch selber festlegen kann).

Verstanden und verinnerlicht - Secure Boot gibt es nicht auf meinem alten Laptop. Vielen Dank für diesen Hinweis.

Beste Grüße

Dieter G. aus K.
Webinar Bild

Schön, dass Ihre Frage beantwortet wurde!

Um weiterhin auf dem Laufenden zum Thema Technik und PC zu bleiben, nehmen Sie doch kostenlos teil an unseren monatlichen LIVE-Webinaren: hier klicken für Registrierungsseite. Bei diesen Online-Shows können Sie uns all Ihre Fragen rund um das Thema Computer stellen und lernen jeden Monat etwas Neues.

  1. vor einer Woche
  2. Linux
  3. # 1 7
noha
VIP
Akzeptierte Antwort Pending Moderation
Hallo Dieter,

die Pause-Taste drückt man immer dann, wenn man anhalten will. Ein erneuter Druck setzt dann fort. Es kann durchaus sein, dass sich der Log-Schirm nicht anhalten lässt, denn wenn der Puffer voll ist, müsste das ganze System halten.

Ich hatte mir vor wenigen Tagen mal Lubuntu angesehen und fand es sehr gut, wenn man nicht die dicken Programme wie Google Chrome oder LibreOffice verwendet. Die kann man natürlich nachinstallieren. Chrome gibt es nur als 64-Bit-Version.
Die ebenfalls genannte Version Xubuntu geht vermutlich ebenfalls verwenden, ist nicht ganz so schlank. Die Grafikoberfläche Xfce gefällt mir wenig; Geschmaksache eben.

Zur Hardware:
Mit der Grafikkarte haben Sie völlig recht, aber ich habe angenommen, dass wegen des großen Speicherverlustes der Rechner keine extra GraKa hat. Unabhängig davon wird bei den PCs immer die Hardware in den Hauptspeicher abgebildet, so dass immer einige MB nicht als Hauptspeicher zur Verfügung stehen.

VG
noha
Webinar Bild

Schön, dass Ihre Frage beantwortet wurde!

Um weiterhin auf dem Laufenden zum Thema Technik und PC zu bleiben, nehmen Sie doch kostenlos teil an unseren monatlichen LIVE-Webinaren: hier klicken für Registrierungsseite. Bei diesen Online-Shows können Sie uns all Ihre Fragen rund um das Thema Computer stellen und lernen jeden Monat etwas Neues.

  1. vor einer Woche
  2. Linux
  3. # 1 8
  • Seite :
  • 1


Es gibt noch keine Antworten zu diesem Beitrag.
Sei der Erste der antwortet.